技术联盟

cocospod 版本更新与更新到指定版本

一、升级本地cocopod到最新版本

1、先切换gem源

gem sources –remove https://rubygems.org/

gem source -a https://gems.ruby-china.org

查看是否切换成功

gem source -l

打印出*** CURRENT SOURCES ***

https://gems.ruby-china.org

就说明切换成功,如果还是官方的源, 请手动重启电脑尝试

2、接下来就可以开始升级了cocoapods了

sudo gem install -n /usr/local/bin cocoapods –pre

3、然后敲下

pod –version  查看最新版本的pod

4、剩下的就是设置pod仓库了

pod setup 重新设置下 pod仓库

 

二、cocopod升级到指定的指定版本

1、在终端输入:sudo gem uninstall cocoapods

显示所有的版本,输入相应的数字,删除不想要的版本

2、在终端输入:sudo gem install cocoapods -v指定版本号

输出:Fetching: cocoapods-1.1.1.gem (100%)

ERROR:  While executing gem … (Errno::EPERM)

Operation not permitted – /usr/bin/pod

3、上面的方法不行,那咱们就换一种输入:sudo gem install -n /usr/local/bin cocoapods -v 指定版本

4、输入pod –version查看一下版本号

 

 

 

Share this:

码字很辛苦,转载请注明来自技术联盟《cocospod 版本更新与更新到指定版本》

评论