技术联盟

eclipse 中安装 maven 插件 ,建立maven工程

 一、插件安装:

1、下载maven插件

打开eclipse ,help-install new software

add

name : m2e

url:        http://download.eclipse.org/technology/m2e/releases/     (今天是2014-2-26,这个地址是有效的,以后不知道是否有效)

 

name : m2e

url:   http://rgladwell.github.com/m2e-android/updates  (2014-4-16,这个地址是有效的,以后不知道是否有效)

 

 

2、下载 maven-bin

下载地址  http://download.csdn.net/download/cyw8998/6963959

 

3、

下载下来之后,解压,找个路径放进去, 把bin的位置,设在环境变量里

新建环境变量MAVEN_HOME , PATH里配置解压后的bin路径

检查一下 进入cmd,运行mvn -v,如果显示出版本号,说明配置成功了。

 

4、

为了使得Eclipse中安装的Maven插件,同windows中安装的那个相同,需要让eclipse中的maven重新定位一下

Window -> Preference -> Maven -> Installation -> Add

 

现在就可以建立maven工程了。

 

二、建立工程:

方法A:

1、打开eclipse,通过工具new  project出现如下窗口:

 

2、选中Maven Project, 点击Next,然后保持默认选项,再点击next,弹出如下窗口

 

3、在过滤器中输入android,如果你已经有这样的插件,将会显示出来,否则就需要通过Add Archetype按钮进行添加

 

4、

3-1、因为我之前已经安装了这三个插件,因此输入过滤器后直接就有了,如果系统没有找到android-quickstart插件,则需点击Add Archetype,弹出如下窗口,然后将所需要的插件的groupid,artifactid及版本号输入进去,根据准备工作中提及,分别是:

de.akquinet.android.archetypes

android-quickstart

1.0.6

如下图所示:

4、点击OK后,系统会去寻找相关的插件,然后选中此插件,再次点击Next,依次填入新工程的groupid, artifactid, package,如下图所示:

 

方法B:

建立一个android工程,之后鼠标右键点工程,选择configure——convert to maven project

 

接下来问题一大堆,头疼,郁闷。一个一个解决吧。

三、问题集合

  1.  

    pom.xml中<packaging>apk</packaging>错误

Project build error: Unknown packaging: apk

在Eclipse中安装[m2e-android][1]插件

安装源:http://rgladwell.github.com/m2e-android/updates/ (2014-2-27这个安装源好使)

安装方法:Help -> Install new Software -> 在出来的对话框中点击 Add ->

 

把如下内容加到pom.xml里边

<build>
<sourceDirectory>src</sourceDirectory>
<outputDirectory>bin/classes</outputDirectory>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.1</version>
<configuration>
<source>1.6</source>
<target>1.6</target>
</configuration>
</plugin>
<plugin>
<groupId>com.jayway.maven.plugins.android.generation2</groupId>
<artifactId>android-maven-plugin</artifactId>
<version>3.7.0</version>
<configuration>
<androidManifestFile>${project.basedir}/AndroidManifest.xml</androidManifestFile>
<assetsDirectory>${project.basedir}/assets</assetsDirectory>
<resourceDirectory>${project.basedir}/res</resourceDirectory>
<nativeLibrariesDirectory>${project.basedir}/src</nativeLibrariesDirectory>
<sdk>
<platform>17</platform>
<path>${env.ANDROID_SDK_HOME}</path>
</sdk>
<emulator>
<avd>SnakeTest</avd>
</emulator>
<deleteConflictingFiles>true</deleteConflictingFiles>
<undeployBeforeDeploy>true</undeployBeforeDeploy>
<attachSources>false</attachSources>
<proguard>
<skip>true</skip>
</proguard>
</configuration>
<extensions>true</extensions>
</plugin>
</plugins>
</build>

 

2、之后发现有一个如下的错误:Project configuration is not up-to-date with pom.xml. Run project configuration update

其实这个问题解决非常简单:在项目上右键——【Maven】——【Update Project Configuration……】这时会打开一个(Update Maven Dependencies)的对话框,然后勾选住出错的项目,点击Ok这样就搞定了。

Share this:

码字很辛苦,转载请注明来自技术联盟《eclipse 中安装 maven 插件 ,建立maven工程》

评论